Background

Authoring Tool Release v0.6.3

Core Developers | February 14, 2019

Can I use Adapt framework 4 in the authoring tool?

Well, following the 0.6.3 release of the authoring tool, yes you can.

For this release, the authoring tool has been patched to pick up the latest configuration settings when you update the framework. We currently only recommend installing framework 4 into new authoring tool setups until a migration strategy has been decided for upgrading from previous versions.

To set up an authoring tool instance running framework 4, follow the standard install guides and during the `node install` section you’ll receive the following prompt:

> Specific git revision to be used for the framework. Accepts any valid revision type (e.g. branch/tag/commit)

Here, enter the desired framework version in the form:

tags/v4.0.1

The list of available tag names may be found here.


Important note: you must be running framework version 2.0.14 or higher to use the 0.6.3 release of the authoring tool.


You can find more technical information for the release in the CHANGELOG.md.